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About Gwyddion

Gwyddion is software for SPM (scanning probe microscopy) data analysis. A few basic
characteristics:

I Free and Open Source – it is not
only free of charge but the full
source code is available, can be
studied, modified, redistributed, etc.

I Multiplatform – it works on
GNU/Linux, Microsoft Windows,
Mac OS X and FreeBSD operating
systems on common architectures.

I Modular – consists mainly of many
small pieces that provide individual
functions, are rather independent
and can be developed
independently by third parties.

http://gwyddion.net/

Gwyddion is mainly focused on 2D raster data (image) analysis. However, it offers also
some functions for 1D (curve) and 3D (volume) data.

D. Nečas and P. Klapetek, Gwyddion: An open-source software for SPM data analysis, Cent. Eur. J.
Phys. 10 (2012) 181-188, doi:10.2478/s11534-011-0096-2
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History
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Development started in 2003, originally motivated by the lack of sufficiently transparent
data processing software for metrology purposes.

The project was founded by two fresh Masaryk University graduates. Nowadays it
supported by the Czech Metrology Institute and being developed by a diverse group of
people from around the world. So far 40+ contributors from 12+ countries have participated
in the project.

After a dozen years Gwyddion includes support for more than 120 data formats and all the
typically used processing routines for SPM data processing, as well as many not so typical
algorithms.
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Overview

What we usually want to do:
1. Open AFM data.
2. Visualise, inspect and explore.
3. Apply levelling and/or corrections.
4. Measure and characterise.
5. Save the results.

Toolbox

Data (image) window
Data browser
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Opening AFM files

Opening an AFM file is simple. Just use File → Open and select the data file(s).

Preview of
file contents

Line correction
and/or
plane levelling
of image preview

Filters, file type – should stay at Automatically detected

Quick access
to favourite
directories

Add/remove
here

Use File → Open Recent → Document History to load files we opened before.
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Toolbox

Tools
    functions you use directly in data windows
    one is active at a time
    each has an associated tool window
    select or measure something interactively

Complete function menu
    ‘set parameters & run’ kind of functions
    organised according to data types
    applied to the active data of corresponding type
    may be insensitive if they require e.g. a mask    

Shortcut buttons
    quicker access to common functions
    subset of functions in the complete menus
    can be customised using Edit → Toolbox

Menus and buttons that are not encircled perform some built-in basic functions:

Information, zoom and 3D view, undo & redo, file management, resource settings.

Everything else are functions provided by modules – we will see later what it means.
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Image window

aspect ratio menu

quick position and value information

image menu

colour palette menu

colour mapping details
are controlled by
Colour Range tool

Right-clicking on the basic data window accesses various common functions and settings.
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Data processing

The image functions are in Data Process menu.

Apply levelling and/or corrections
I mean-plane subtraction Level → Plane Level
I predominant-plane subtraction Level → Facet-Level
I three-point plane subtraction Tools → Three-Point

Level
I polynomial levelling Level → Polynomial Background
I smart base plane flattening Level → Flatten Base
I row correction Correct Data → Align Rows

Measure and characterise
I simple measurements Tools → Read Value, Distance
I profile extraction Tools → Profile
I statistical parameters Tools → Statistical Quantities
I statistical distributions Tools → Statistical Functions

Many of these functions are tools.
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Using tools

1. Select the Profile tool
in the toolbox.

2. The Profile tool window appears
with a preview.

3. Select line(s) in the data window
adjust parameters in the tool window.

4. pressing Apply creates
the resulting profile graph
we can use graph functions.
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Graph window

Graph menu, the same as in the toolbox

Curve properties

Axis properties

Key properties

Curves can be dragged and dropped from Curves tab to other graphs.
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OpenGL 3D view

expand/collapse
controls

3D view mouse
    R (rotate)
    S (scale)
    V (value-scale)
    L (light source)

set current view
(with all settings)
as the default
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Saving results

Processed data
I Always save to GWY files (.gwy).

They can contain all data types, selections, . . .

Text export
I Scalar results (statistics or tables) – Copy or

Save buttons
I Graph curves – use Graph → Export Text
I Image data (single) – Save with .txt extension

Image export
I Images – Save with an image

extension: .png, .pdf, .svg,
. . .

I 3D rendering – use the Save
button

I Ctrl-C copies window contents
to the clipboard
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Browsing data

What is the last window shown in the overview? It is called Data Browser.

What it can do?
I show all the various data in the current file and information about them

(M/P/C image flags, number of curves in graphs and spectra, volume data levels)
I show, hide, rename, duplicate and delete individual data
I drag and drop data to another file
I close entire files

If we lose the data browser Info → Show Data Browser shows it again.

When all data (images, graphs, etc.) of a file are closed the entire file is closed.

When a file is imported from non-GWY format only the first data found in the file is shown.
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Data kinds

Images (height fields, height maps, data fields) – the main kind of data in Gwyddion. Most
functions work with images. Images can have various other kinds of data associated
with them: masks, presentations, selections, . . .

Graphs – usually the result of some data reduction, but can also be loaded directly. A
bunch of functions is available in the Graph menu.

Single point spectra (SPS) – F-D, I-V or other curves measured at specific coordinates.
The cannot exist standalone in Gwyddion; must be merged with the corresponding
image files. The Spectro tool extracts SPS to graph curves.

Volume data – usually spectra measured in each image point. A few basic operations are
available, together with several functions to fit F-D volume data or extract data of
lower dimensionality.

XYZ data – data fields measured in irregular point sets. The newest addition so far; only a
few functions are available.

Missing: It seems XYZ spectra, i.e. curves measured in irregular point sets are the future in
SPM. However, taming this beast is tough.
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Masks, presentations and selections

While correcting or analysing images, we often make use of auxiliary data.

Three important kinds of auxiliary data that can be attached to an image in Gwyddion are
masks, presentations and selections.

The first two are images; the last are geometrical shapes ‘drawn’ on the data with mouse.

mask of marked grains

shading presentation

underlying data
 
all data processing
operations use the data

composed data view

points (with radii) rectangle lines (with widths and numbers)lattice
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Metadata and logs

The last auxiliary pieces of information we
mention are metadata and logs.

Metadata
I any additional parameters or information we

can read from the SPM file
I there can be none at all, or hundreds of

structured items
I entirely instrument and file format specific
I editable – we can add our own items (or

even change existing)

Log
I the record of all performed operations
I contains name of the operation, parameters

and time
I can be removed and/or disabled if we do not

like it

Both are accessible from the right-click menu of
images and volume data (graphs and spectra do
not have them).
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Common features

Standard SPM data processing features:
I 2D and 3D views and graphs
I value and profile reading
I geometrical transforms
I image merging
I line levelling
I plane and polynomial levelling
I three-point levelling
I denoising filters
I statistical characterisation
I roughness measurement
I slope distribution
I grain marking and measurement
I Fourier transform
I wavelet transform
I edge detection
I . . .
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Uncommon features

Some uncommon and odd features:
I processing of data under arbitrarily

shaped masks, including:
I value reading
I profile extraction
I statistical quantities
I value & slope distributions
I ACF, HHCF, PSDF, . . .
I plane & poly levelling
I filtering

I artificial data generation
I frequency space synthesis
I deposition models
I regular patterns
I Ising-like models
I various noise types

I feedback loop simulation
I lateral force simulation
I tip modelling and blind estimation
I tip convolution and erosion
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Uncommon features (continued)

I various curious statistics:
I Minkowski functionals
I entropy
I area scale graph

I angularly averaged profiles
I affine distortion correction
I drift correction
I lattice vector measurement
I calibration and uncertainty calculation
I force-distance curve fitting
I volume spectra processing
I XYZ data processing
I facet analysis
I correlation search, cross-correlation
I MFM modelling
I point spread function estimation
I neural network data processing
I . . .
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Basic structure

Main Gwyddion components:
I Libraries, providing basic and advanced

data processing routines, graphical user
interface elements and other utility
functions and objects.

I The program, quite small and simple,
serving primarily as a glue connecting the
other components together in a common
graphical interface.

I Modules, technically run-time loaded
libraries, that provide actual user-facing
functionality. They are well-separated and
can be developed by third parties. They
often extensively use library methods.

GLib

Gwydion base and
data processing
librariesCairo, Pango, ... FFTW

Gdk, Gtk+, ...

Gwyddion UI and module libraries

Modules: file, data processing, ...

LibXML2, Minizip, ...

Gwyddion (the program)

Gwyddion relies heavily on a set of open source libraries from the GTK+ stack:
I the GLib system library for portability, GObject object system and various utility

functions
I GTK+ toolkit for the graphical user interface (while adding a fair number of new

widgets for data visualisation)

Plus FFTW is used for FFT, compression and file format libraries for file handling, . . .
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Module information

modules

file

pygwy.so

apedaxfile.so

gwyfile.so

iso28600.so

nanoscope.so

...

process

arithmetic.so

basicops.so

level.so

otsu_threshold.so

...

graph

...

tool

...

volume

...

We can see the list of modules in Info → Module Browser.

There is approximately a bazillion of them because essentially
every function or data format is provided by its own module.
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Constructing the toolbox

modules

file

pygwy.so

apedaxfile.so

gwyfile.so

iso28600.so

nanoscope.so

...

process

arithmetic.so

basicops.so

level.so

otsu_threshold.so

...

graph

...

tool

...

volume

...

custom ui/toolbox.xml

(you do not actually need to edit some
XML files, just use Edit →Toolbox)

+ =

custom toolbox
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User directory

Where the ui/toolbox.xml file lives?

In the Gwyddion user directory:
I ~/.gwyddion in Unix systems
I Some\Kind\Of\User\Directory\gwyddion in MS Windows

It contains various things:
I definitions of toolbox and keyboard shortcuts (in ui)
I settings, i.e. remembered values of all adjustable parameters
I resources, such as user false colour gradients
I presets, i.e. named parameter sets for instance for image export
I . . .

This can be useful when we want to send some of these thing to a colleague or transfer
them to a new computer.
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Opening a file

One customization possibility is writing new
modules. This is an specialised topic. We will
just demonstrate how modularity works.

What happens when we open a file?

I The program calls function
gwy_file_open() for the file.

I All 120+ file modules are asked: Can you
load this file?

I Each file module examines the file
contents and returns a score.

I Higher score means the module is more
confident it can load this file.

I A winner is chosen.
I This module is finally asked to load the file.
I It loads all the importable data and returns

something called GwyContainer.
I From this point everything is as if we

opened a Gwyddion GWY file.
I In fact, this is how we load GWY files too.
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What is in a GWY file?

The data browser shows the content of a GWY file as some images, spectra, graphs, etc.

We know the file can also contain masks, presentations, selections, metadata, false colour
mapping settings, 3D view settings, logs, etc.

Actually, we might not talked about some of these but they are there anyway. . .

When we save data to a GWY file and
open it later, all these things are restored.

Understanding the data organisation is
also very useful for scripting.

So what is really inside?

At the top level, a GWY file consists of
something called GwyContainer.

It contains all the various pieces of data.
They are identified by names looking
exactly like (Unix) file paths.

GWY files are binary. However, there is a
useful program gwydump that can print
their contents in a human-readable form.

gwydump -v -t -d 1 file.gwy
Header GWYP
"" object=GwyContainer
   "/0/data" object=GwyDataField
   "/0/data/log" object=GwyStringList
   "/0/data/title" string="Topography Left"
   "/0/data/visible" boolean=TRUE
   "/0/mask" object=GwyDataField
   "/0/mask/alpha" double=0.499992
   "/0/mask/blue" double=0.0321813
   "/0/mask/green" double=1
   "/0/mask/red" double=0
   "/0/meta" object=GwyContainer
   "/0/select/pointer" object=GwySelectionPoint
   "/1/data" object=GwyDataField
   "/1/data/log" object=GwyStringList
   "/1/data/title" string="Topography Left"
   "/1/data/visible" boolean=TRUE
   "/1/mask" object=GwyDataField
   "/1/mask/alpha" double=0.499992
   "/1/mask/blue" double=0.0321813
   "/1/mask/green" double=1
   "/1/mask/red" double=0
   "/1/meta" object=GwyContainer
   "/1/select/pointer" object=GwySelectionPoint
   "/1/select/rectangle" object=GwySelectionRectangle
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What is in a GWY file?

The data for the first image is called "/0/data".

The data for the second image is called
"/1/data".

The mask for the first image is called "/0/mask".

Some of the naming rules may seem odd. The
reason is compatibility. Somewhat odd data names
are better than breaking compatibility with older
versions.

If we look in more detail, again using gwydump, we
can see that an image has again some named
components. And some of the components have
their own components. . .

Altogether, a GWY file is a tree.

Unlike the coarse view, this level of detail is seldom
useful, even in scripting.

If we want to read or write GWY files in a
standalone program, there is a library for that –
libgwyfile.

gwydump -v -t file.gwy
Header GWYP
"" object=GwyContainer
   "/0/data" object=GwyDataField
       "xres" int32=256
       "yres" int32=255
       "xreal" double=5e-05
       "yreal" double=4.98047e-05
       "si_unit_xy" object=GwySIUnit
           "unitstr" string="m"
       "si_unit_z" object=GwySIUnit
           "unitstr" string="m"
       "data" double array of length 65280
   "/0/data/log" object=GwyStringList
       "strings" string array of length 8
   "/0/data/title" string="Topography Left"
   "/0/data/visible" boolean=TRUE
   "/0/mask" object=GwyDataField
       "xres" int32=256
       "yres" int32=255
       "xreal" double=5e-05
       "yreal" double=4.98047e-05
       "si_unit_xy" object=GwySIUnit
           "unitstr" string="m"
       "si_unit_z" object=GwySIUnit
           "unitstr" string=""
       "data" double array of length 65280
   "/0/mask/alpha" double=0.499992
   "/0/mask/blue" double=0.0321813
   "/0/mask/green" double=1
   "/0/mask/red" double=0
   "/0/meta" object=GwyContainer
       "AcAmpl" string="2"
       "AcEnable" string="False"
       "AcFreq" string="328000"
       "Angle" string="0"
       "Mode" string="Contact"
       "SampBias" string="5.960465E-07"
       "SetPoint" string="0.8000305"
       ...
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Pygwy

Python scripting, called pygwy for short – it is
also the name of the Gwyddion module which
adds the Python scripting capability.

In fact, it can refer to three different things.

Pygwy console – allows running Python scripts
inside Gwyddion, executing various program
functions, mixing manual data processing and
automation.

Standalone scripts – Python programs that run
outside Gwyddion, import gwy and utilise its
functions to process SPM data.

Loading a file can be as simple as:

import gwy
data = gwy.gwy_file_load(’somefile.afm’)

Pygwy console with a script

Of course, we are now running Python, not Gwyddion. So while we still have lots of
functions available, some things only make sense only inside Gwyddion itself.

The last option is to write Gwyddion modules in Python. This is a bit more involved –
nevertheless simpler than in C (which is the norm).
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Using Gwyddion functions

When doing any of the above things, we must distinguish two styles (shown as C code for a
change but it translates directly to Python):

Using library functions – happily poking in our images or other data, not caring in the
least about Gwyddion, the program:

GwyDataField *datafield = gwy_data_field_new(400, 400, 3e-6, 3e-6, FALSE);
gwy_data_field_fill(datafield, 3.0);

Pretending to be Gwyddion – running functions from modules and generally managing
data like Gwyddion does.

This may be the only way to utilise some functionality provided by modules.

However, it is less straightforward:

...
gwy_container_set_enum_by_name(settings, "/module/facet-level/mode",

GWY_MASK_EXCLUDE);
gwy_app_data_browser_select_data_field(data, id);
gwy_app_run_process_func_in_mode("facet-level", GWY_RUN_IMMEDIATE);
...

With some care we can mix and match the two styles.
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Driving custom built instrumentation

We can employ Gwyddion’s data format handling,
data processing, visualisation and other utility
functions in other tasks.

Instrumentation development at CMI & CEITEC:
I voice coil based large area SPM instruments
I nanoindentation devices
I spectroscopic digital reflectometry
I special metrology SPM system (with ISI ASCR)
I large area low cost system (with ISI ASCR)



Gwyddion Beyond SPM data analysis David Nečas 31 / 33

Driving custom built instrumentation

GwyScan is a simple SPM control software based on Gwyddion libraries, compatible with
our voice coil, piezoelectric, stick slip and PiezoWalk based SPMs.

All the hardware related functionality is only a single file with less than 1000 lines of code.

This approach has various

Benefits: Lightweight libraries, most data handling in the application, versatile system
applicable virtually to anything, open-source licensing.

Drawbacks: No direct support for data acquisition (like in Labview), no direct support for
any SPM instrumentation related tasks (like in GXSM).
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Something completely different

Uncharted is a imaging spectrophotometry data visualisation software used in our
CEITEC group.

It uses Gwyddion widgets for visualisation.

The data are fitted using another Gwyddion-based program (command line, nothing to
show here).

Parameter maps are written in the Gwyddion GWY file format.
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Conclusion

Conclusion:
I Use Gwyddion for your SPM data analysis.

Thank you!
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