Комбинации клавиш

КомбинацияЭквивалент менюКонтекстДействие
F1 все окнаОткрывает соответствующий раздел руководства пользователя в браузере.
Ctrl-Q Файл → Выйти окно инструментов, окно данных, окно трёхмерного просмотра, окно графика, окно инструментаВыйти из Gwyddion.
Ctrl-O Файл → Открыть окно инструментов, окно данных, окно трёхмерного просмотра, окно графика, окно инструментаОткрыть файл данных.
Ctrl-S Файл → Сохранить окно инструментов, окно данных, окно трёхмерного просмотра, окно графика, окно инструментаСохранить текущие данные (будет предложено имя файла, если оно ещё не связано с данными).
Ctrl-Shift-S Файл → Сохранить как окно инструментов, окно данных, окно трёхмерного просмотра, окно графика, окно инструментаСохранить текущие данные под другим именем. Имя файла, связанного с данными будет изменено на другое.
Ctrl-W Файл → Закрыть любая разновидность окна данных (изображение, 3D, XYZ, объём, график), окно инструментов, браузер данныхЗакрыть файл, содержащий текущие данные.
Ctrl-Shift-M Файл → Объединить окно инструментов, окно данных, окно трёхмерного просмотра, окно графика, окно инструментаДобавить данные из файла к текущему файлу.
Ctrl-H Файл → Последние файлы → Предыдущие документы окно инструментов, окно данных, окно трёхмерного просмотра, окно графика, окно инструментаОткрыть окно просмотра предыдущих документов (или показать его окно поверх остальных, если оно уже открыто).
Ctrl-DСделать копию в браузере данныхлюбая разновидность окна данных (изображение, 3D, XYZ, объём, график), окно инструментов, браузер данныхСделать дубликат данных в текущем окне как нового блока данных в том же файле.
Ctrl-InsertИзвлечь в новый файл в браузере данныхлюбая разновидность окна данных (изображение, 3D, XYZ, объём, график), окно инструментов, браузер данныхСоздать новый файл, содержащий только текущий блок данных.
Ctrl-DeleteУдалить в браузере данныхлюбая разновидность окна данных (изображение, 3D, XYZ, объём, график), окно инструментов, браузер данныхУдалить текущий блок данных из файла
Ctrl-Z Правка → Отменить окно инструментов, окно данных, окно трёхмерного просмотра, окно графика, окно инструментаОтменить последний шаг обработки, применённый к текущим данным.
Ctrl-Y Правка → Повторить окно инструментов, окно данных, окно трёхмерного просмотра, окно графика, окно инструментаПовторить последний шаг обработки, применённый к текущим данным.
Ctrl-K Правка → Удалить маску окно инструментов, окно данных, окно трёхмерного просмотра, окно графика, окно инструментаУдалить маску с текущего окна данных.
Ctrl-Shift-K Правка → Удалить презентацию окно инструментов, окно данных, окно трёхмерного просмотра, окно графика, окно инструментаУдалить презентацию с текущего окна данных (изображения).
F3 окно данных, окно инструмента, окно инструментовПоказать окно инструментов, если оно скрыто. Скрыть окно инструментов если оно показывается.
Ctrl-Shift-BПросмотр метаданных (в контекстном меню)окно изображения, данных XYZ или объёмных данныхПоказать окно просмотра метаданных для отображаемых данных.
+ любая разновидность окна данных (изображение, 3D, XYZ, объём, график)Приблизить изображение в текущем окне данных.
= любая разновидность окна данных (изображение, 3D, XYZ, объём, график)Приблизить изображение в текущем окне данных.
- любая разновидность окна данных (изображение, 3D, XYZ, объём, график)Отодвинуть изображение в текущем окне данных.
Z любая разновидность окна данных (изображение, 3D, XYZ, объём, график)Масштабировать текущее окно данных до масштаба 1:1.
Ctrl-F Обработка данных → Повторить последний окно инструментов, окно данных, окно трёхмерного просмотра, окно графика, окно инструментаПрименить к текущим данным последнюю функцию обработки данных с использованными в последний раз параметрами. Обычно операция будет тихо и незаметно повторно применена к данным, но если данный шаг обработки невозможен без участия человека, будет показано диалоговое окно.
Ctrl-Shift-F Обработка данных → Повторить с настройкой последний окно инструментов, окно данных, окно трёхмерного просмотра, окно графика, окно инструментаПоказать ещё раз диалог параметров последней функции обработки данных. Если операция не требует установки параметров, она будет проведена незамедлительно.

Можно присвоить свои комбинации клавиш всем функциям в меню, также возможно вызывать инструменты комбинацией клавиш.

Чтобы изменить комбинацию клавиш для пункта меню просто нужно выбрать его с помощью мыши или клавиш-стрелок, нажать требуемую комбинацию клавиш, и она незамедлительно будет установлена. Комбинация клавиш должна быть или специальной клавишей, т.е. F3, или сочетанием, включающим модификаторы, т.е. Ctrl-Shift-D. Нельзя присваивать просто буквенно-цифровые клавиши, такие как Q.

Чтобы предотвратить случайное изменение комбинаций клавиш, они могут меняться только при включенной опции Правка → Комбинации клавиш. Изменения по умолчанию выключены, что рекомендуется делать при обычном использовании.

Все комбинации клавиш хранятся в файле ui/accel_map в каталоге пользователя, который обычно называется ~/.gwyddion (Unix) или Documents and Settings\gwyddion (MS Windows). Присвоить комбинации клавиш инструментам можно только путём редактирования этого файла. Каждая строка соответствует действию, вызываемому этой комбинацией клавиш. Например, строка для инструмента "Редактор маски" по умолчанию выглядит так:

; (gtk_accel_path "<tool>/GwyToolMaskEditor" "")

Точки с запятой обозначают комментарии, т.е. строки. начинающиеся с них будут неактивными. Следовательно, чтобы присвоить сочетание клавиш Ctrl-Shift-E инструменту "Редактор маски", удалите точку с запятой чтобы сделать эту строку активной и запишите своё сочетание клавиш в пустое место между кавычками:

(gtk_accel_path "<tool>/GwyToolMaskEditor" "<Control><Shift>e")